Unable to load Legacy Provider

Matt Caswell matt at openssl.org
Fri Apr 22 10:33:39 UTC 2022

On 22/04/2022 08:26, Gahlot, Ashish Kumar wrote:
> Hi,
> I’m trying to load the Legacy Provider by following this guide here 
> https://wiki.openssl.org/index.php/OpenSSL_3.0 
> <https://wiki.openssl.org/index.php/OpenSSL_3.0> using this following code:
> /* Load Multiple providers into the default (NULL) library context */
>         legacy = OSSL_PROVIDER_load(NULL, "legacy");
>         if (legacy == NULL) {
>             printf("Failed to load Legacy provider\n");
>             exit(EXIT_FAILURE);
>         }
> But it fails to load the legacy provider. I also tried to by editing the 
> configuration file but I get the same error. I’m using “OpenSSL 3.0.0 7 
> sep 2021 (Library: OpenSSL 3.0.0 7 sep 2021)”.

Most likely it is not finding the legacy.so file in its default location.

The default directory for these modules is returned by:

openssl version -m

Check that directory to make sure legacy.so exists there.

If you have legacy.so in some other location you can specify it by 
setting the OPENSSL_MODULES environment variable to the alternative 

If the above doesn't help then one other thing to try is to dump out the 
OpenSSL error stack to see if you get any clues from that, e.g. by 
adding the following to your code:



> Thank you,
> Ashish
> Notice: This e-mail together with any attachments may contain 
> information of Ribbon Communications Inc. and its Affiliates that is 
> confidential and/or proprietary for the sole use of the intended 
> recipient. Any review, disclosure, reliance or distribution by others or 
> forwarding without express permission is strictly prohibited. If you are 
> not the intended recipient, please notify the sender immediately and 
> then delete all copies, including any attachments.

More information about the openssl-users mailing list